FedEx API Down
Incident Report for POSPortal
Resolved
Update at 6:43AM PDT, the FedEx third party shipping API is on-line.
Posted Apr 17, 2017 - 06:44 PDT
Identified
At 6:20AM PDT, it has been identified that the FedEx third party shipping API is down.
Posted Apr 17, 2017 - 06:21 PDT