Merchant Control Center - Down
Incident Report for POSPortal
Resolved
This issue has been resolved.
Posted Jan 09, 2017 - 14:14 PST
Monitoring
The issue has been identified and addressed. This will continue to be monitored to ensure the issue is resolved.
Posted Jan 09, 2017 - 08:50 PST
Identified
We have identified an issue with our Merchant Control Center platform. Clients might experience issues logging in and/or processing requests. Our staff is currently working to resolve the issue at this time.
Posted Jan 09, 2017 - 08:24 PST