MCC/Direct Slow
Incident Report for POSPortal
Resolved
We did not find any issues on either MCC/Direct platforms.
Posted Sep 20, 2019 - 09:15 PDT
Investigating
We are investigating reports that our MCC and Direct platforms are running slow.
Posted Sep 20, 2019 - 07:44 PDT
This incident affected: Merchant Control Center and Direct Merchant eCommerce.