UPS's Address validation is "Service Temporarily Unavailable.
Incident Report for POSPortal
Resolved
The service has been restored.
Posted 10 months ago. Nov 09, 2018 - 19:05 PST
Identified
A issue with one of the service providers is currently causing issues with placing orders within Portal Access. We are monitoring the system and will provide updates.
Posted 10 months ago. Nov 09, 2018 - 10:47 PST
This incident affected: Portal Cloud.