Portal Access - Order Placement
Incident Report for POSPortal
Resolved
The issue has been resolved at this time.
Posted Sep 06, 2021 - 13:19 PDT
Investigating
We have received reports that accessing Merchants and Order Placement through Portal Access is currently unavailable. We are investigating the reports and will post an update shortly.
Posted Sep 06, 2021 - 13:06 PDT
This incident affected: Portal Cloud.