Merchant Control Center Degraded performance
Incident Report for POSPortal
Resolved
This incident has been resolved.
Posted Jan 30, 2020 - 09:37 PST
Investigating
We are currently investigating this issue.
Posted Jan 29, 2020 - 12:01 PST
This incident affected: Merchant Control Center.