Merchant Control Center Degraded performance
Incident Report for POSPortal
Resolved
We have identified the root cause and have implemented a short term fix to resolve the system issue. The application team is currently working on a long term solution.
Posted Jan 28, 2020 - 15:17 PST
Investigating
We are currently investigating this issue.
Posted Jan 28, 2020 - 11:15 PST
This incident affected: Merchant Control Center.